Tidelift Status

Degraded performance and timeouts

Resolved
Web UI API
Degraded Performance

Update: We have resolved the source of degraded performance and timeouts that was earlier affecting the Tidelift application.

Earlier: We are currently investigated degraded performance of the Tidelift application. This is manifesting with long load times for pages as well as some timeouts. We will update by 6pm ET.